How to enable windows installer while in safe mode

Brian Richards
Brian Richards
21
Aug 2011

How to enable windows installer while in safe mode

comment icon18 comment(s) |

Recently I came across a computer that was getting a bluescreen every time it booted up unless it was booted into safe mode.  I traced the problem to a particular program but when I tried to uninstall it in safe mode, I was unabe to because the windows installer service is unavailable in safe mode by default.  The following commands will add the windows installer service back to your safe mode (with networking) session.  Just copy and paste them into the run-line:

REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Network\MSIServer" /VE /T REG_SZ /F /D "Service"

follow that with:

net start msiserver

Comments

April 6, 2012

Zurwyn

Invalid Syntax

Whenever I type REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Network\MSIServer" /VE /T REG_SZ /F /D "Service" into the Command Prompt, it successfully completes.

But when I type net start msiserver, I get an error saying:
This service cannot be started in Safe Mode

Here's a link to a pic of my problem that I took.
http://i991.photobucket.com/albums/af40/suge181181/MSIerror.jpg

Did I do anything wrong?

Thanks in advance,
Zurwyn

August 10, 2012

Ryan

Your issue in the screenshot

Your issue in the screenshot is that you're missing the " after MSIServer

January 27, 2013

Ronoc

Thank you for posting this.

Thank you for posting this. It worked!

I changed the first line from ...SafeBoot\Network\MSIServer... to ...SafeBoot\Minimal\MSIServer... this made the change active to Safe Mode without networking.

March 14, 2013

Anonymous

God bless you!!

God bless you!!

May 2, 2013

thank you motherfucker

holy shit

this nigger is on FIRE

BRIAN RICHARDS

GIVE EM THE DICK

May 6, 2013

techie

Could not uninstall from safe mode with networking

Thanks a lot for your help. It worked perfect in Windows 7 64bit.

May 8, 2013

Anonymous

Slight Correction

The correct command is :
REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Network\MSIServer" /VE /T REG_SZ /F /D "Service"

More info:
http://www.symantec.com/connect/blogs/windows-installer-safe-mode

May 28, 2013

Proka

Thank you!

Thank you!

July 22, 2013

Anonymous

Thanks a lot!! Still works in

Thanks a lot!! Still works in Windows 8.1

September 5, 2013

Tina

yes it worked.

Thank you.. It worked.. But typing it on command prompt was long task so used a small module for doing so. anyway it worked ..thank you.

October 25, 2013

LBarto

Worked great! I had an issue

Worked great! I had an issue with windows 7 64bit installing VMWare ViewAgent. After i installed it and rebooted, i had no login prompts; i could not enter in any username.
Knowing the issue i tried to uninstall it but ran into this delightful error.

December 6, 2013

wolfkiss

Just what I needed - Thank You!

I just copied and pasted into the Search box and Bingo! Good stuff. Thank you very much!

December 25, 2013

Rob

Absolute Genius Thank You!

Absolute Genius Thank You!

February 5, 2014

David Voňka

thank you very much, also for

thank you very much, also for the "minimal" advice

February 8, 2014

Anonymous

I typed in the command as it

I typed in the command as it showed. Command is good. But when I type in net start msiserver, it tells me "the service cannot be started, either because it is disabled or because it has no enabled device associated with it". Anyone? Thanks!

February 8, 2014

Anonymous

Nevermind, I tried something

Nevermind, I tried something else. It's working now. Thanks anyway! Great blog!

February 10, 2014

Anonymous

I am getting a sytax error

I am getting a sytax error every time I try to input the first command.
Any ideas?

April 20, 2014

Karac

Thank you SO MUCH man! I do

Thank you SO MUCH man! I do computer repair and this will definitely help. I appreciate your looking into this very much.

+1

Search